Rover12421's Blog

The End.

Eclipse4.2安装Antlr3IDE插件

        貌似在Mac OS里运行Eclipse 4.2没啥太大问题,所以就暂时不折腾Eclipse 3.7了.在安装Antlr的插件Antlr3IDE 的时候出了点小问题,Eclipse 3.7是自带了dltk(Dynamic Languages Toolkit) 3.x的版本,而用Juno 更新源里只能更新4.x的版本,看了下3.7的Juno里也是4.x的.没办法,只好自己去下3.x的dltk了.如果不使用3.x的dltk会提示下面的错误:

Cannot complete the install because one or more required items could not be found.
  Software being installed: ANTLR IDE- JDT Integration (optional) 2.1.2.201108281759 (org.deved.antlride.feature.integration.jdt.feature.group 2.1.2.201108281759)
  Missing requirement: ANTLR IDE- JDT Integration (optional) 2.1.2.201108281759 (org.deved.antlride.feature.integration.jdt.feature.group 2.1.2.201108281759) requires ‘org.eclipse.dltk.core [3.0.0,4.0.0)’ but it could not be found

        dltk3的最后一个版本是3.01,这个版本不是rc版本,无所谓了.下载页面是:http://download.eclipse.org/technology/dltk/downloads/drops/R3.0/S-3.0.1-201108261011/,太多了,拉到最下面下面,有2个all-in-1的包,随便下一个就可以,我下的是带updateSite的包.安装zip的时候又报错...
Your original request has been modified.
  "Dynamic Languages Toolkit - Remote Development Support" will be ignored because a newer version is already installed. 
  "Dynamic Languages Toolkit - Mylyn Integration" will be ignored because a newer version is already installed. 
  "Dynamic Languages Toolkit - Core Frameworks" will be ignored because a newer version is already installed. 
Cannot complete the install because one or more required items could not be found.
  Software being installed: Dynamic Languages Toolkit - Python IDE SDK 2.0.0.v20090730-1514-4--84M22NfWGJIEgQf08I00CdNBH (org.eclipse.dltk.python.sdk.feature.group 2.0.0.v20090730-1514-4--84M22NfWGJIEgQf08I00CdNBH)
  Missing requirement: Dynamic Languages Toolkit - Python IDE 2.0.0.v20090730-1514-7H--BcMAGGAYMY (org.eclipse.dltk.python.feature.group 2.0.0.v20090730-1514-7H--BcMAGGAYMY) requires 'org.eclipse.dltk.core.feature.group [2.0.0,3.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Dynamic Languages Toolkit - Python IDE SDK 2.0.0.v20090730-1514-4--84M22NfWGJIEgQf08I00CdNBH (org.eclipse.dltk.python.sdk.feature.group 2.0.0.v20090730-1514-4--84M22NfWGJIEgQf08I00CdNBH)
    To: org.eclipse.dltk.python.feature.group [2.0.0.v20090730-1514-7H--BcMAGGAYMY]

        先前安装了4.x的,自动忽略3.x,还有一个是提示PythonIDE没有安装,这个没必要安装,Antlr3IDE需要的是core包,这个all-in-1里带了很多其他语言的,都是可以去掉的.
        卸载前面安装的4.x的dltk,忽略不要的语言tools,安装成功.
Unistall Dltk4.x
       接下来继续安装Antlr3IDE,一路顺利.不过Antlr3IDE是托管在sourceforge上的,国内现在访问异常缓慢,能翻墙的还是翻墙安装吧.
g4 file
        高亮的落,效果还行.细心的会发现我用的扩展名是g4,恩,确实,赶时髦嘛,用的是antlr4哦.虽然这个插件不支持最新的antlr4,但是高亮还是能用了,这就足够.

Comments